Reduced Build and Editor Availability
Minor incident
Dashboard
NVIDIA Graphics Delivery Network (GeForce NOW)
Sessions Service
World Builder Service
Worlds Service
Morpheus Platform
2025-06-05 11:40 BST
· 2 hours, 13 minutes
Updates
Resolved
June 5, 2025 · 13:52 BST
This service outage has now been confirmed resolved for all customers.
De-escalate
June 5, 2025 · 13:38 BST
Service has been restored for all customers; we are continuing to monitor and verify the platform is operating normally.
Investigating
June 5, 2025 · 13:33 BST
Most customers have now had build access restored, including editor and pixel streaming access.
Investigating
June 5, 2025 · 13:01 BST
We have restored build access for some customers, and are continuing to restore access for others.
Investigating
June 5, 2025 · 12:07 BST
We have identified the issue, and are planning resolution steps.
Investigating
June 5, 2025 · 11:59 BST
We are investigating an issue around build availability.
- Editor downloads are currently unavailable.
- Some Worlds may fail to launch.
- Pixel streaming is unavailable for some worlds.
← Back