Nvidia GFN Touch Controls

Minor incident Morpheus NVIDIA Graphics Delivery Network (GeForce NOW)
2025-08-06 16:03 BST · 1 day, 18 hours, 17 minutes

Updates

Resolved

Nvidia have released a new version of their SDK which resolve this issue.

This has been added to v0.10.3 of the @msquared/pixel-streaming-client. If you were affected by this issue please upgrade to the new version as soon as possible

August 8, 2025 · 10:18 BST
De-escalate

We have identified that this incident is caused by a regression introduced by Nvidia’s latest SDK version.

MSquared have worked with Nvidia to make their previous, working SDK version available.

If you are impacted by this issue we would recommend updating your @msquared/pixel-streaming-client library to v0.7.2 until Nvidia have fixed the regression in their latest SDK version

August 7, 2025 · 09:50 BST
Investigating

We have identified the issue as a regression caused by an update of Nvidia’s streaming platform, and are working with them to roll back these changes or identify a workaround.

August 7, 2025 · 08:29 BST
Investigating

Nvidia are continuing to investigate the issue - we will continue to provide updates when available

August 6, 2025 · 17:14 BST
Investigating

We are actively investigating an issue which is preventing touch input on any embedded pixel streaming experience.

We will provide updates once available

August 6, 2025 · 16:03 BST

← Back