Nvidia GFN outage
Minor incident
Morpheus
NVIDIA Graphics Delivery Network (GeForce NOW)
2025-08-08 17:54 BST
· 17 hours, 50 minutes
Updates
Resolved
August 9, 2025 · 11:44 BST
We have monitored this issue and can confirm that service has been restored
Monitoring
August 8, 2025 · 20:13 BST
Nvidia have implemented a fix and service has been restored.
We will monitor this issue and will resolve or re-open accordingly.
Issue
August 8, 2025 · 17:54 BST
Nvidia GFN are experiencing an outage which is preventing users from accessing any MSquared experiences via pixel streaming.
We are working with them to resolve this issue. We will provide updates once available
← Back