GFN Embedded streams

Major incident Morpheus NVIDIA Graphics Delivery Network (GeForce NOW)
2025-10-02 10:35 BST · 3 hours, 27 minutes

Updates

Resolved

This issue has now been resolved.

Please reach out to your support engineer if you are still having issues

October 2, 2025 · 13:08 BST
Issue

We are aware of an issue that is preventing GFN from loading in embedded experiences.

GFN is loading from the Morpheus dashboard but not if the experience is embedded on a website.

Nvidia are investigating this issue as a priority and we will provide updates.

October 2, 2025 · 10:35 BST

← Back