Pak Embedding / Fast Play interruption
Major incident
Morpheus
NVIDIA Graphics Delivery Network (GeForce NOW)
2025-11-06 12:03 GMT
· 5 days, 1 hour, 49 minutes
Updates
Resolved
November 11, 2025 · 13:51 GMT
This issue has now been resolved - Fast play / Pak embedding is now working as expected from the dashboard.
Please reach out to support if you’re continuing to see issues
Issue
November 10, 2025 · 12:03 GMT
Due to issues with Nvidia’s service, Pak embedding / Fast Play is currently not functioning. Build are failing to upload to Nvidia’s service.
This issue is being actively investigated by both Nvidia and MSquared - we will provide updates in due course.
(This is an update to the previous incident stating that there was a delay to Fast Play / Pak Embedded builds)
← Back
Services Status